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1 Introduction

This is the official guide for the SugarCRM Adapter for SAP Cloud Integration. This guide covers all
relevant information for the installation of the SugarCRM adapter and its plug-in where applicable.

Please read this guide carefully before using the SugarCRM adapter.

Coding Samples

Any software coding and/or code lines/strings ("Code") included in this documentation are only
examples and are not intended to be used in a productive system environment. The Code is only
intended to better explain and visualize the syntax and phrasing rules of certain coding. We do not
warrant the correctness and completeness of the Code given herein.

1.1. Internet Hyperlinks

The documentation may contain hyperlinks to the Internet. These hyperlinks are intended to serve as
a hint about where to find related information. We do not warrant the availability and the
correctness of this related information or the ability of this information to serve a particular purpose.

2 Package Content

This section provides the details of the files that are provided as part of the installation package of
the SugarCRM Adapter. It is assumed that the bundle is downloaded from the SAP Marketplace
which would contain files listed in Sections 0 and 0.

Adapter

The SugarCRM Adapter installation package consists of the files below:

File Name Description
sapcpi-sugarcrm-adapter.esa Adapter .esa File
Plug-in

The SugarCRM Adapter plug-in installation package consists of the files below:

File Name Description

SugarCRM-plugin.jar The Eclipse Plug-in or workbench file
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3 Prerequisites
To use the document, the following aspects are assumed:

e The Adapter bundle is downloaded from the SAP Marketplace.

e You have have downloaded and installed the SAP recommended version of Eclipse. Currently,
Eclipse Oxygen is preferred. To get the latest SAP recommendation, visit the link:
https://tools.hana.ondemand.com/#cloudintegration.

4 Adapter Installation

Depending on whether your SAP CPI tenant is on Neo or Cloud Foundry, please proceed with either
Section 0 or 0.

Adapter Installation for Neo

The adapter archive file (.esa) can be found from the ZIP file downloaded from the SAP Marketplace
under the folder: /SUGARCRM_1.00.0/bundles. The file is called “sugarcrm.esa”.

In the Neo environment, before it can be used, the adapter needs to be deployed to the SAP Cloud
Integration tenant. You need to have Eclipse installed on your computer to perform the deployment.
Note that currently it is recommended to use Eclipse Oxygen. The following high-level activities need
to be performed:

1. Configuring Eclipse
2. Deploying the adapter

We discuss each one of the above tasks in the next sections.

4.1.1 Configuring Eclipse
To configure your Eclipse installation, proceed as follows:

e Install SAP Cloud Integration Tools for Eclipse by following the steps specified at:
https://tools.hana.ondemand.com/#cloudintegration.

e From your Eclipse installation, click on Windows > Preferences to reach a page similar to
below. Provide the URL of your Neo tenant, a username, and Password. You can use the Test
Connection button to ensure that the provided details are correct.
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https://tools.hana.ondemand.com/#cloudintegration
https://www.eclipse.org/downloads/packages/release/oxygen/3a/eclipse-jee-oxygen-3a
https://tools.hana.ondemand.com/#cloudintegration

@] preferences O X

type filter text Operations Server
Bemoteystems 2 Specify the connection details
Run/Debug
Salastorce Adupies URL: l https://-tmn.hci.em.hana.ondemand.com v ‘ ®
v SAP Cloud Platform Integration User: _ ‘
Operations Server paseword: _ ‘

Server .
ServiceNow Adapter Test Connection
Sonarlint

Team

Terminal
Validation
Web

Web Services
XML

Apply and Close Cancel

Figure 4-1: SAP Cloud Integration Operations Server Settings
e Click on Apply and Close to proceed.

Now that Eclipse is successfully configured, you can deploy the adapter.

4.1.2 Deploying the Adapter
To Deploy the adapter using Eclipse that proceed as follows:

e Change the perspective in Eclipse to Integration Operations by clicking on the Open

Perspective icon (ﬁj0 ) on the right corner of Eclipse, then choose the Integration Operations
perspective.

&

##Debug A
an GQit

% Integration Operations

& Java

& Java Browsing

+2 Java EE (default)

%’Java Type Hierarchy

& JavaScript

4 JPA M

Use F2 to display the description for a selected perspective.

Figure 4-2: Selecting the Integration Operations Perspective
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From the resulting window, double click on your tenant ID. This is the Folder icon (~*) on the
right side of the screen, under the Node Explorer tab. You then get a screen with the list of
Deployed Artifacts similar Figure 4-3.

fiNode Explorer & = ‘3.-'3 i)
Server URL: https://-tmn Deployed Artifacts &
viE type filter text l Deploy%‘
' _ Name Version Type Node Type Deploy S... 7 A Undeploy
v [ Workday_1.0.0_Read_ 1.0.0 BUNDLE  IFLMAP  DEPLOYED 1 =
B AP DynamicsCRM_1.00.( 1.0.3 BUNDLE  IFLMAP  DEPLOYED 1 Downloa
= e AWS_SWF_ WorkFlow_ 1.0.0 BUNDLE  IFLMAP  DEPLOYED 1
sirevar: I AWS_SWF_WorkFlow_ 1.0.0 BUNDLE IFLMAP  DEPLOVED 1
AWS_SWF_WorkFlow_ 1.0.0 BUNDLE  IFLMAP  DEPLOYED 1

Figure 4-3: Deployed Artifacts

Click on the Deploy button on the right side as shown in Figure 4-3. A new window will then
appear similar to Figure 4-4. Select the Integration Adapter option and click next.

)
&

Select a wizard

Select artifact type to deploy

B Integration Adapter

B Known Hosts (S5H)

B 0Auth? Authentication
EIPGP Public Keyring
EIPGP Secret Keyring

B Secure Parameter

Bl User Credentials

Figure 4-4: Selecting Integration Adapter

You will be prompted with a subsequent screen, enabling you to select the Bundle or the
Adapter file that you downloaded from the bundle with the name sugarcrm.esa; see Figure
4-5. Then click Finish.
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Select integration content archive to deploy

Tenant: p0262

Bundle:* |C:\Users\CF\downloads\sapcpi-sugarcrm-adapter.esa Browse...

@ < Back Next > Cancel

Figure 4-5: Selecting the Bundle to be Deployed.

e After a successful deployment of the adapter, you will receive the message shown in Figure
4-6.

=

& : L

‘@ Deployment of Integration Content Archive artifact(s) for tenant-successfully finished.

Figure 4-6: Successful Deployment of Integration Content Archive

Adapter Installation on Cloud Foundry

Before the adapter can be used in the Cloud Foundry environment, it needs to be deployed to the
SAP Cloud Integration tenant.

4.1.3 Prerequisites

Before installing the adapter using this approach, ensure that the following prerequisites are in
place:

e There should not be any .esa file of the SugarCRM Adapter in the SAP Integration Suite
Design workspace. In case this package exists, remove the .esa file from the Design
workspace.

e The package “SugarCRM Adapter for SAP Integration Suite” should not be in the Design
workspace of the SAP Integration Suite tenant. In case this package exists, delete it.
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4.1.4 Adapter Installation via the Design Tab

It is important to note that there is no manual way of installing the SugarCRM Adapter. The following
procedure explains how the SugarCRM Adapter is migrated from the Discover workspace to the
Design workspace of the SAP Integration tenant.

Proceed as follows:

Navigate to the Design tab to access the workspace.

Select the integration package where the integration flow is to be created.
Choose Edit to enable editing of the package.

Navigate to the Artifacts tab. Choose Add and elect Integration Flow.

AW

Integrations / SugarCRM_integration /

e SugarCRM_integration

Header ~ Overiew  Arifacts  Documents  Tags

Add v Migrate

[] Name Type

SOAP API

No data

Value Mapping
OData API

Script Collection
RESTAPI

Message Mapping
Function Libraries
Integration Adapter
Data Type

Message Type

Figure 4-7: Creating an Integration Flow

5. Create an integration flow and supply a name.
6. Proceed to the newly created integration flow and click on Edit.
7. Select End. Choose the arrow-right icon (-2').
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8. Drag the pointer to the Receiver box.

-_...".' Integration Process

L2 Receiver

PN

Start End

Figure 4-8 Selecting the receiver adapter

9. Select the SugarCRM adapter.

Adapter Type C

SugarCRM (Vendor: rojoconsultancy.com)

Cancel

Figure 4-9 Select the SugarCRM Adapter

Note that the SugarCRM adapter is already available in the list of adapters.

10. After selecting SugarCRM Adapter, the Adapter is imported into the Design workspace of the
SAP Integration Suite tenant

Import

Importing the integration adapter
"SugarCRM"

Close

Figure 4-10: Import of SugarCRM adapter

11. Once the package is imported, the adapter deployment is triggered.

'SugarCRM ' is triggered for
deployment.

Figure 4-11 SugarCRM adapter deployment
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12. Once the SugarCRM Adapter is deployed, a success message is displayed.

'SugarCRM' successfully
deployed.

Figure 4-12 Successful deplpyment message

4.1.5 Importing the Adapter without Integration Flow Creation

Alternatively, t
@ D’.r:;-u'r-rwiﬁ‘i-\

ALL

B
2 package(s) found
P aneciad Mdagee or SAF g e ok

. =
) oo e ot o T T T e e o S P ST e T ) he

SugarCRM Adapter can also be imported into the Design workspace without creating an integration
flow. This method is useful for scenarios where integration flow packages are migrated from
development to a higher environment (Example: Production).

Use Transport Management Service (TMS) to import/transport the SugarCRM Adapter to a higher
environment.

If the TMS option is not available in the landscape, the Adapter Package can be imported from the
Discover workspace to the Design workspace via the copy option of the former.

Proceed as follows to copy the integration package and import the SugarCRM Adapter:

1. Navigate to the Discover tab.
2. Using the search box, search for “SugarCRM Adapter for SAP Integration Suite”

3. Select the “SugarCRM Adapter for SAP Integration Suite” package.

4. Navigate to the Copy option. Doing so copies the said package from the Discover workspace
to the Design workspace.

SugarCRM Adapter for SAP Integration Suite
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5. Navigate to the Design workspace and select the “SugarCRM Adapter for SAP Integration
Suite” package.

6. Select Artifacts, and choose the Deploy action to deploy the SugarCRM Adapter.

SugarCRM Adapter for SAP Integration Suite

Deploy

4.1.6 Monitor the Deployment Status

After deploying the adapter, it is important to check if it has been correctly deployed to your tenant
by navigating to “Operations View”, then to “Manage Integration Content”.

Overview / Manage Integration Content

Integration Content (501) | sugad X Q |

Name Status l

SugarCRM Started

Integration Adapter

Figure 4-13: Checking the status of the deployed Integration Adapter

5 Plug-in Installation Steps
Please follow the steps below to install SugarCRM Adapter in Eclipse Oxygen:

1. Download Eclipse Oxygen 3a from the URL:

https://www.eclipse.org/downloads/packages/release/oxygen/3a

2. Onceinstalled, copy the SugarCRM Plug-in JAR file.
3. Go to your installation folder (e.g.: C:\Program Files (x86)\oxygen\eclipse).

4. Open the Plug-ins folder and paste the SugarCRM Plug-in JAR file. The exact name of the file
can be found in Section 0.

5. Open Eclipse Oxygen.

6. Go to Windows > Perspective > Open Perspective > Other (See Figure 5.1).
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i3 Projects - ccipse
File Edit Navigate Search Project Run Window  Help

(mlhd @<~-i@in|mm @& NewWindow

Editor >
&

&5 Project Explorer e, 5
Show View >
Perspective >
Navigation >
>

‘Web Browser
Preferences

Q-G

Open Perspective
Customize Perspective.
Save Perspective As..
Reset Perspective.
Close Perspective

Close Al Perspectives

Figure 5-1: Changing perspective

@ Open Perspective

cE-imE P vi0iRd

5| 45 Debug
& Java
& PA
[&5 Resource
@ Web

Other...

7. Select SugarCRM Workbench and click Open (See Figure 5.2).

#)ava Browsing

2 Java EE (default)
’Java Type Hierarchy
&' JavaScript

@ JPA

@ Planning

2= Plug-in Development
EBRemote System Explorer
[y Resource

@ SugarCRM Workbench
&'Team Synchronizing

Figure 5-2: Selecting the Adapter Perspective

Go to Window > Preferences.

Window Help
New Window
Editor

Appearance

Show View

Perspective
Navigation

Web Browser

Preferences [

>

>

vy @ v Q-

Figure 5-3: Selecting the Preference Option
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9. Select SugarCRM Adapter Plug-in. Fill with your SugarCRM Address, Username, Password,
and Client ID. These details can be obtained in your SugarCRM tenant.

SugarCRM Adapter Plugin ey T

SugarCRM Settings
Address ‘ https:/ I o2ropencloud.eu

Client ID ‘ sugarTest

HEhEEF

Client Secret

User ‘ admin
Password e P ]
Platform ‘ base

Test connection

Restore Defaults Apply

Figure 5-4: SugarCRM Perspective

The Section 11.1 (Finding SugarCRM Address) of the SugarCRM Adapter Guide explains how
to obtain your Address. Furthermore, for the Client ID, you will need to create an app on
your SugarCRM tenant. You can find the details about in Section 4 (SugarCRM Configuration)
of the SugarCRM Adapter Guide. Validate credentials and if there are no issues, click on
Apply and Close.

10. If the configuration details are correct, you will get a Login successful message as shown in
Figure 5-5. Ensure that the connection is successful before proceeding to use the adapter
and the plug-ins.

Save data in secure store %

+ Login successful

Test Connection;

Restore Defaults Apply

Figure 5-5: Successful Connection of Plug-in

To start using the adapter and the plug-in, refer to the SugarCRM Adapter Guide.
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